XDK demo flash
Answer
11/13/17 5:43 AM

Hello there,
I am trying to flash the VirtualXdkDemo  onto the XDK, but the flashing is aborted everytime due to a compilation problem.

It seems that the issue occurs because theres no folder "debug" under "SensorUtils" folder.

I get the following Error Messages in the console:

14:00:02 **** Build of configuration XDK Default for project VirtualXdkDemo ****
mingw32-make debug 
D:\XDK-Workbench\make\mingw32-make.exe -C D:\XDK-Workbench\SDK/xdk110/Common -f application.mk debug
old_bootloader
mingw32-make[1]: Entering directory 'D:/XDK-Workbench/SDK/xdk110/Common'
D:\XDK-Workbench\make\mingw32-make.exe -C ./../Platform/SensorUtils debug BCDS_COMMON_MAKEFILE=D:/XDK-Workbench/SDK/xdk110/Common/common.mk
mingw32-make[2]: Entering directory 'D:/XDK-Workbench/SDK/xdk110/Platform/SensorUtils'
      0 [main] us 0 init_cheap: VirtualAlloc pointer is null, Win32 error 487
AllocationBase 0x0, BaseAddress 0x60EA0000, RegionSize 0x160000, State 0x10000
D:\XDK-Workbench\msys\mkdir.exe: *** Couldn't reserve space for cygwin's heap, Win32 error 0
D:/XDK-Workbench/SDK/xdk110/Common/common.mk:113: recipe for target 'D:/XDK-Workbench/SDK/xdk110/Platform/SensorUtils/debug/object/source/AxisRemap/AxisRemap.o' failed
mingw32-make[2]: Leaving directory 'D:/XDK-Workbench/SDK/xdk110/Platform/SensorUtils'
Libraries.mk:67: recipe for target '../Platform/SensorUtils/debug/libSensorUtils_efm32_debug.a' failed
mingw32-make[1]: Leaving directory 'D:/XDK-Workbench/SDK/xdk110/Common'
mingw32-make[2]: *** [D:/XDK-Workbench/SDK/xdk110/Platform/SensorUtils/debug/object/source/AxisRemap/AxisRemap.o] Error 1
mingw32-make[1]: *** [../Platform/SensorUtils/debug/libSensorUtils_efm32_debug.a] Error 2
Makefile:32: recipe for target 'debug' failed
mingw32-make: *** [debug] Error 2

 

I use the 3.1.0 XDK-Workbench 64bit which is freshly installed on a Win 7 64bit system. 

Can you give me some advice, how to fix the Workbench or to replace the missing file to succesfully compile this?

0 (0 Votes)
RE: XDK demo flash
Answer
11/13/17 2:55 PM as a reply to luri lee.

Hi Luri Lee,

 

I tried to recreate your issue and was able to verify the same error using XDK Workbench v3.1.0. This isn't ideal but reverting back to XDK Workbench v2.0.1 allows the build to finish successfully. I did not test v3.0.1. As you pointed out, this seems to just be a folder issue.

 

The next issue I ran into is that if you are using an XDK with Firmware v1.1.0 (built in 2017), after flashing I received an "Invalid Application" error similar to below in the output. I have found this error in multiple XDK example files.

 INFO | Transmission successfully completed!
 INFO | Booting application...
 INFO | XDK DEVICE 1:  Invalid application

 

Franjo Stjepandic describes how to fix this below

https://xdk.bosch-connectivity.com/community/-/message_boards/message/307086

 

I tested an older XDK with Firmware v0.0.9 and XDK Workbench v2.0.1 and was able to successfully flash and run the application (viewed on iPad) without issue.

 

-Matthew

 

Edit: Added invalid application fix from Franjo Stjepandic

0 (0 Votes)
RE: XDK demo flash
Answer
11/13/17 5:19 PM as a reply to Matthew Krugh.

Hello guys,

First of all, I would like to thank you for your additional insight and help Matthew. But I assume the issue lies somewhere else.

The issue is not that the folder debug under SensorUtils is missing. Rather than that, because of the issue, that folder does not get created at all.

The issue seems to be a memory issue with one of the programs used to compile the project. cygwin does not get space, according to the line

D:\XDK-Workbench\msys\mkdir.exe: *** Couldn't reserve space for cygwin's heap, Win32 error 0

One possible solution would be to restart the computer, to reset memory, at least if the computer had been running for a long time up to that point. cygwin uses persistent memory, which may become corrupted over time, and is not reset automatically.

Alternatively, try running the XDK-Workbench with Admin privileges. Perhaps cygwin does not get space because it is not authorized to get space.

As a last resort, try reinstalling the XDK-Workbench, by first uninstalling everything XDK-Workbench related, downloading the Workbench again and installing the fresh download.

Please tell me if this was helpful and do not hesitate to ask further questions.

Kind regards,
Franjo

0 (0 Votes)