Device registration failure
Answer
3/9/18 5:18 PM

Can someone help me with the issue that I am facing with device registration ? You can find the error log as given below. Other devices work well with the platform.

 

 

 

INFO | Flashing file 'C:/XDK-Workbench/workspace/Bosch/debug/Lwm2mExampleClient.bin'...

INFO | XDK DEVICE 1: c

INFO | XDK DEVICE 1: CRC

INFO | Application checksum 'e056' successfully verified.

INFO | Transmission successfully completed!

INFO | Booting application...

INFO | XDK DEVICE 1: b

INFO | XDK DEVICE 1:  Jumping to application

INFO | Connecting to XDK device 'XDK Device 1' in port 'COM3'...

INFO | Connection to port 'COM3' established

INFO | XDK DEVICE 1: Network init/connection failed 386

 INFO | Set device 'XDK Device 1' into bootloader mode

INFO | Connecting to XDK device 'XDK Device 1' in port 'COM3'...

INFO | Connection to port 'COM3' established

INFO | XDK DEVICE 1:   Ip address of the device *********

 INFO | XDK DEVICE 1:  Network Initialization done

INFO | XDK DEVICE 1: PAL_initialize

INFO | XDK DEVICE 1: PAL Initialization done

INFO | XDK DEVICE 1: PAL_socketMonitorInit

INFO | XDK DEVICE 1: PAL SocketMonitor done

INFO | XDK DEVICE 1: IP Address of the Device is ***********

INFO | XDK DEVICE 1: Lwm2mInterface Initialization start

INFO | XDK DEVICE 1: Lwm2m_initialize

INFO | XDK DEVICE 1: done

INFO | XDK DEVICE 1: Lwm2m Interface done

INFO | XDK DEVICE 1: Lwm2m Interface start with given port

INFO | XDK DEVICE 1:  Ip address of the server ***********

INFO | XDK DEVICE 1:  coap without encryption

INFO | XDK DEVICE 1: Lwm2m Interface started

INFO | XDK DEVICE 1: LCA Initialization Done

INFO | XDK DEVICE 1: Registration process has started

INFO | XDK DEVICE 1: registration failed M=0x1A, E=0x10, S=0x2 (0x1A90)

 

0 (0 Votes)
RE: Device registration failure
Answer
3/12/18 8:11 AM as a reply to Archana Punnoose.
Hello Archana,

I have tested the Lwm2mClientExample in an attempt to reproduce your issue, but I did not get a registration failure message. In fact, the error code 0x1A90 states that this is simply a registration error.

The only things I changed in the example were the WiFi settings and the port defined in Lwm2mExampleClient.h, i.e. WLAN_CONNECT_WPA_* and CLIENT_CONNECT_PORT, although the port variable does not seem to affect registration at all.

My guess is that the XDK's registration messages are dropped by your router. If there are any logs available on whether the registration message is sent successfully or not, I would recommend to take a look there.

Otherwise, if this is not the case, could you tell me what changes you made and whether you can communicate with the LWM2M Server (which is the Leshan Eclipse Server by default) from within your network at all? You could test this by pinging the server from a command line interface (on your PC). The default IP address is 5.39.83.206.

Please tell me if this was helpful, and do not hesitate to ask further questions.

Kind regards,
Alex
0 (0 Votes)