SD Card is not working
Answer
8/9/18 7:42 AM

Dear all,

i have bought a SanDisk micro SDHC 16GB to use the DataLogger. Unfortunately that card is not accepted by the XDK. Does anybody know how to solve the problem?

Thank you!

 

0 (0 Votes)
RE: SD Card is not working
Answer
8/9/18 5:25 PM as a reply to Alexander Ramsel.
Hello Alexander,

Gladfully, your issue has not to be hardware sided. To determine it, I need some more information:

Is there any LED indication on the XDK about that error?
For example:
  1. Red LED is blinking every 0.5 sec means, that no SD has been found.
  2. Red LED is blinking every 1 sec means, that no logger.ini file has been found
  3. Red LED is permanently on means, that an internal error occured (probably software sided)


In addition to that, could you please check the file format of you SD card? Is it FAT32, exFat or NFTS?

Please tell me if this was helpful, and do not hesitate to ask further questions.

Kind regards,
Franjo
0 (0 Votes)
RE: SD Card is not working
Answer
8/10/18 10:35 AM as a reply to Franjo Stjepandic.

Thanks for your help.

The Red LED is blinking every 1 sec but in fact the logger.ini is copied on the card. The file format is FAT32. Some SD-Cards are working fine and some not.

Best reagards

Alex

0 (0 Votes)
RE: SD Card is not working
Answer
8/10/18 1:46 PM as a reply to Alexander Ramsel.
Hello Alexander,

Could you please check if your Windows operating system is changing the ending of your file from logger.ini to logger.ini.txt . This might be caused by Windows settings, which are messing with the file endings.

Since you said that some SD cards are working and others not, are these from the same manufacturer?

Are all of them from the standard SDHC with the filesystem FAT32?

Please let me know if this was helpful and feel free to ask if you have further questions.

Kind regards,
Franjo
0 (0 Votes)