XDKCloudConnectivity IoT Things
Answer
11/5/18 10:32 AM

Hi,

I got a problem with connecting the XDK via the XDKCloudConnectivity Template, provided in the workbench (3.1), to the IoT Things Cloud.

The issue is always the same: The XDK get stuck at "booting application..."

My procedure is

- paste config info onto SD Card (16gb, class 10) as config.txt with adapted SSID and PW

- put that SD card into XDK

- Connect XDK via USB (so it is connected and visible in Workbench as in boorloader mode)

- In Workbench (3.1) Create new project with the BoschXDKCloudConnectivity template

- Project -> Clean..

- Project -> Build Project

- Flash XDK

- then after some time it just get stuck at "Firmware Version: 0000000"

- Rebooting the application gets it stuck at "Booting application.."

- Meanwhile no LEDs light up when tyring to reboot. Only a short blip of the red LED on turning off and on the XDK.

 

I'm trying it on an wifi network with wpa security level.

 

What am I doing wrong? Or where do I miss out on anything?

Are there additional configurations that I have to do?

 

Thank you very much for your help and advice in advance!

 

0 (0 Votes)
RE: XDKCloudConnectivity IoT Things
Answer
11/6/18 11:39 AM as a reply to Steffen Ramm.

Does nobody have an idea or a clue?

Thanks a lot!

0 (0 Votes)
RE: XDKCloudConnectivity IoT Things
Answer
11/6/18 5:08 PM as a reply to Steffen Ramm.

Steffen,

It looks like you are taking all the right steps.  From your description you are getting stuck in the flashing stage.  When you hit the flash button does the yellow LED start flashing?  If not the the device is never flashed.

Have you tried flashing any other project, like the LedsAndButtons example?  This will let you know if there is something wrong with workbench.

If this also fails I would try and reinstall the workbench, and you may at this point want to try and update the workbench to 3.4.0.

0 (0 Votes)
RE: XDKCloudConnectivity IoT Things
Answer
11/6/18 11:15 PM as a reply to BCDS Tester.

Steffen,

As luck would, or would not, have it a colleague of mine ran into this issue today.  I ran through the previous steps and stopped short of reinstalling the workbench.  Everything else worked, and at my disposal was another XDK that I proved the BoschXDKCloudConnectivity project worked on.  So I knew the issue was not with the Workbench, but rather something was wrong with their XDK!  Now that I have you worried, I think I have found the solution.

First the deep dive explaination:

In the event that the SD Card is not inserted, or not read, the code immediately starts to look at the WiFiFileSystem.  If it finds the config.txt file in this storage medium it will read the file and try to move on.  The code will place the config.txt in this storage medium after reading it from the SD Card the first time and then change the file in the SD Card to config.bkp and you will bypass the SD Card after that.  If the config.txt file is wrong in the WiFiFileSystem you are stuck.

Check the file on your SD Card and see if this it ends in .bkp, if so please change it back to config.txt.  A couple things to edit in your config.txt file on the SD Card.  Make sure there are no spaces or tabs at the end of each line (unless required by your Password or SSID).  Please add a new line to the end of your file.

Christopher Koch

0 (0 Votes)
RE: XDKCloudConnectivity IoT Things
Answer
11/7/18 3:59 PM as a reply to BCDS Tester.
Hello Steffen and Chris,

First of all thank you, Chris, for the detailed explanation and approach.
I would like to add another possible error source. Which again has to do with the config.txt file on your SD card.

To check this thesis, please open your config.txt file with an editor. If your system runs on Windows, I recommend using the windows editor to open the file.

When your file is opened, click on File and Save as from the top menu.
Left, next to the save button, within the saving popup window, you can select an encoder.
Please be sure you selected ANSI and overwrite your old file by saving the ANSI encoded config.txt to your SD card.

After this step, please try again to clean, build and flash the original BoschXDKCloudConnectivity example (3.3.1) on Workbench 3.3.1.

In addition, I would suggest updating your Workbench to the newest version 3.4.0.

Please let me know if this was helpful and feel free to ask if you have further questions.

Kind regards,
Franjo
0 (0 Votes)