Hello,
In two cases I discover a timing problem with my XDK USB connection.
  1. As I open up the XDK IDE it takes up to 10 Minutes until the “Discover devices” process could find the XDK at USB port 26 (see image #1 ,#2). During this process I can disconnect the XDK and then the XDK IDE recognizes within seconds that it is not available (image #3). In this case there seemed to run two discover processes in parallel (image #4). Only after minutes the XDK then is correctly recognized (image #5).
  2. Similar behavior I find in using “Sensor Monitor V2” Java application on my Windows PC. As I start the application there is no connection at all. As I start the “setting menu” it takes up to 10 Minutes until the menu appears (image #6). Then I can configure the right port (image #7) and everything is fine.   
Looks like the discover process has a timing issue here. Any idea what I could do?
Stefan
0 (0 Votes)
XDK needs up to 10 Minutes to get USB connection with XDK IDE or Sensor Mon
Answer
5/4/15 7:16 AM as a reply to Stefan Ferber.
Hello stefferber,

we have seen similar problems in the past with certain Bluetooth Adapters that create virtual COM ports. Those virtual COM ports may cause significant delays when listing the existing ports.

To verify this problem, could you please try to disable the virtual COM ports coming from your bluetooth adapter? In the past, disabling bluetooth altogether had the desired effect.

In case this helps in your case, please let us know. We will then try to find a more practical solution.


Regards

Bastian

 
0 (0 Votes)