Hi guys,

I want to use the "StreamSensorDataOverUSB" example with all sensors.

But I get a error shown in the image.

Is a Error Code list with explanations available?

0 (0 Stimmen)
RE: StreamSensorDataOverUSB All Sensors w/ Noise
Antwort
27.09.18 14:14 als Antwort auf Florian W.
Hello Florian,

The Package ID 153 in your screenshot is a good indicator for the location where to look at.
In your case with the Package ID 153 pointing to the XDK application you are currently using. For the module ID and the return code, I recommend taking a look at XdkCommonInfo.h , which is located at /SDK/xdk110/Common/include/ .

The Module IDs in your case 37 can be found within enum XDK_Common_ModuleID_E , which lists all the Module IDs. Simply hover your mouse cursor over the enumberations, to see the ID.
ID 37 relates to XDK_COMMON_ID_NOISESENSOR .

The Error code itself gives the last hint, which finds itself listed in the enum XDK_Common_Retcode_E , also within the file XdkCommonInfo.h. In your case, ID 166 belongs to RETCODE_NO_DATA_ON_QUEUE , which leads to the conclusion, your noise sensor does not handle out the data as it should.

Did you change anything like for example the delay or any values that manipulate vTaskDelay(pdMS_TO_TICKS(APP_CONTROLLER_TX_DELAY)); in the example, which could affect the reading/sending data rate of the sensors?

Please let me know if this was helpful, and do not hesitate to ask further questions.

Kind regards,
Franjo
0 (0 Stimmen)
RE: StreamSensorDataOverUSB All Sensors w/ Noise
Antwort
30.09.18 16:37 als Antwort auf Franjo Stjepandic.

Hi, thanks for your response.

Yesterday I was able to get it running, but today it does not work again :/

I noticed that enabling only noise or all without noise does work fine. Just when I want to use the noise sensor in combination with another one, the program shuts down.

Btw. I use Workbench 3.4.0 on macOS.

0 (0 Stimmen)
RE: StreamSensorDataOverUSB All Sensors w/ Noise
Antwort
01.10.18 14:49 als Antwort auf Florian W.
Hello Florian,

thank you for providing further information.

I will try to reproduce the behavior in order to find an appropriate solution. On that behalf, are you using the latest macOS High Sierra?

Kind regards,
Franjo
0 (0 Stimmen)
RE: StreamSensorDataOverUSB All Sensors w/ Noise
Antwort
06.10.18 13:32 als Antwort auf Franjo Stjepandic.

Hello Franjo,

currently I am working on macOS Mojave.

I tried the code on a Linux Manjaro aswell. In this case the Noise Sensor outputs always the same value.

Kind regards,
Florian

0 (0 Stimmen)
RE: StreamSensorDataOverUSB All Sensors w/ Noise
Antwort
08.10.18 11:34 als Antwort auf Florian W.
Hello Florian,

Thank you for providing additional information about your operating system. In regards to Linux, the behavior is an already known and reported bug.

Furthermore, I will test the behavior on macOS Mojave too.

Kind regards,
Franjo
0 (0 Stimmen)