XDK - Data Logger configuration
Antwort
30.03.16 17:07
Dear Colleagues,

since a few days i'm trying to log recorded data from the sensors to a SD Card. But no data are being recorded. I follow all steps in other threads and also from the user manual, but it still not working.
I muss also say that the red LED is always on(according to user manual, internal error?).

Here the content of my "logger.ini" file:
[general]
; Specify filename in sprintf format
filename=log_%04i.csv
; Output file format: [csv, json, custom]
fileformat=csv
; Output data format: [raw, unit]
dataformat=raw

[bma280]
; Sensor enabled? [0, 1]
enabled=1
; Sensor Sampling Rate in Hz: [0.0001 - 1000]
sampling_rate=1000
; Sensor Range in +- g: [2, 4, 8, 16]
range=2
; Sensor Bandwidth in Hz (or unfiltered): [7.81, 15.63, 31.25, 62.5, 125, 250, 500, unfiltered]
bandwidth=500

[bmg160]
; Sensor enabled? [0, 1]
enabled=1
; Sensor Sampling Rate in Hz: [0.0001 - 1000]
sampling_rate=500
; Sensor Bandwidth in Hz (or unfiltered): [32, 64, 12, 23, 47, 116, 230, unfiltered]
bandwidth=32

[bmi160]
; Sensor enabled? [0, 1]
enabled=1
; Sensor Sampling Rate in Hz: [0.0001 - 1000]
sampling_rate=250
; Accelerator Sensor Range in +- g: [2, 4, 8, 16]
range=2
; Accelerator Sensor Bandwidth in Hz (or unfiltered): [7.81, 15.63, 31.25, 62.5, 125, 250, 500, unfiltered]
bandwidth_accel=500
; Gyroscope Sensor Bandwidth in Hz (or unfiltered): [32, 64, 12, 23, 47, 116, 230, unfiltered]
bandwidth_gyro=32

[bmm150]
; Sensor enabled? [0, 1]
enabled=1
; Sensor Sampling Rate in Hz: [0.0001 - 1000]
sampling_rate=200
; Sensor Datarate in Hz (or unfiltered): [10, 2, 6, 8, 15, 20, 25, unfiltered]
data_rate=25

[bme280]
; Sensor enabled? [0, 1]
enabled=0
; Sensor Sampling Rate in Hz: [0.0001 - 1000]
sampling_rate=100
; Sensor Oversampling  (or off): [off, 1, 2, 4, 8, 16]
oversampling=4
; Sensor Filter Coefficient  (or off): [2, 4, 8, 16, off]
filter_coefficient=4

[MAX44009]
; Sensor enabled? [0, 1]
enabled=0
; Sensor Sampling Rate in Hz: [0.0001 - 1000]
sampling_rate=100
;Sensor Integration Time in ms [800, 400, 200, 100, 50, 25, 12.5, 6.5 ]
integration_time=50

Can someone helps me out?

Thanks in advance

kind Regards
 
0 (0 Stimmen)
XDK - Data Logger configuration
Antwort
30.03.16 17:00 als Antwort auf Marco Schott.
Hello,

I had the same issue as i was trying to reproduce the problem in the an other thread.
You have to be sure, that the SD-Card is blank, expect the two files. 

If you are using windows there come every time more hidden files on the SD-card.
These files cause problems with the application and the XDK is not running.
  
There is also an issue with the fileending if you are using windows 8 or higher versions of windows.
Here you have to be sure that the endingtype is correct and not hidden set to .txt

In your case, I think that the hidden files causes the problem.

Please tell me, if this solves your problem.

Kind regards,
Manuel
0 (0 Stimmen)
XDK - Data Logger configuration
Antwort
31.03.16 07:15 als Antwort auf Manuel Cerny.
Hello Manuel,
thanks for your answer. I'm actually not using de custlog.ini file, cause i use the csv fileformat.
Im actually on Windows 7 and also ensured that the SD Card has an FAT32 filesystem. Furthermore i searched for hidden files on my Micro SD card, but there are no hidden files. I'm desperated.... I'll try with another Micro SD card and let you know.

Kind Regards
 
0 (0 Stimmen)
XDK - Data Logger configuration
Antwort
31.03.16 10:02 als Antwort auf Marco Schott.
Hello,

of course, you don't need to use the custlog.ini file if you want to use csv as your output format.
You can find the supported SD-cards here.

- Manuel
0 (0 Stimmen)
XDK - Data Logger configuration
Antwort
31.03.16 11:38 als Antwort auf Manuel Cerny.
Hello Manuel,
i just used another SD-Card(SCHD) and guess what? It works!
Much Thanks for your support.

Kind regards

 
0 (0 Stimmen)
XDK - Data Logger configuration
Antwort
31.03.16 19:44 als Antwort auf Marco Schott.
Hi,

great to hear!
Just let me know, if you have other questions.

- Manuel
0 (0 Stimmen)
RE: XDK - Data Logger configuration
Antwort
22.07.16 03:29 als Antwort auf Marco Schott.

Hi,

I met the same problem with you before. Firstly make sure that your SD card is in FAT32 mode which less than 32GB, then format your card, and try again.

Regards

0 (0 Stimmen)