XDK console not printing anything.
Risposta
19/09/19 13.45

Dear Support,

Good morning. I just installed the XDK workbench and I'm trying to develop a simple application for my Bosch sensor. 

I'm running into a problem, though: no matter what application I develop, I always build the project, flash the file successfully, but nothing appears on the console in the workbench. 

I even successfully replicated a version of the HelloWorld task as explained in the official youtube channel, but the problem persists: after the device is connected to the workbench, the console just doesn't print anything whatsoever.  

Down below I'm pasting what the console prints:

 

INFO | Creating Firmware Over the Air (FOTA) Container
 INFO | Binary File: C:\Users\gianluca.dore\XDK-Workspace\Hworld\debug\Hworld.bin
 INFO | Header Version: 0100
 INFO | Product Class: 0010
 INFO | Product Variant: 0000
 INFO | Firmware Version: 00000000
 INFO | Flashing file 'C:/Users/gianluca.dore/XDK-Workspace/Hworld/debug/Hworld.bin'...
 INFO | XDK DEVICE 1: Ready
 INFO | XDK DEVICE 1: C
 INFO | XDK DEVICE 1:
 INFO | XDK DEVICE 1: XMODEM Download Success
 INFO | XDK DEVICE 1:  CRC of application area
 INFO | XDK DEVICE 1:  CRC00002998
 INFO | Application checksum '2998' successfully verified.
 INFO | Transmission successfully completed!
 INFO | Booting application...
 INFO | XDK DEVICE 1:  Performing application CRC validation (this will take a couple of seconds)
 INFO | XDK DEVICE 1:  Jumping to application
 INFO | Port 'COM9' has been disconnected
 INFO | Connecting to XDK device 'XDK Device 1' in port 'COM9'...
 INFO | Connection to port 'COM9' established

 

and then nothing whatsoever. 

Is my device flawed or am I doing something wrong? Nothing is displayed even if I opened a template and just put a printf as first thing in main.c.

0 (0 Voti)
RE: XDK console not printing anything.
Risposta
23/09/19 8.41 come risposta a Lorenzo Vottero.

Hi,

Can you check the whether device is in Bootloder mode and also the version of the Bootloader.The screenshot is attached for reference.

Thanks,

Ann Treesa.

0 (0 Voti)
RE: XDK console not printing anything.
Risposta
23/09/19 13.34 come risposta a Ann Treesa.

Hello Ann Treesa,

Thanks for your support.

Yes, I checked if the device was in bootloader mode, and the version is 1.2.0.

I actually tried a different application now. I flashed on the device the LedAndButtons sample application, after doing a clean and a build of the project. The application works quite well, but I noticed that if I edited the code, adding or editing the functions, the application still runs like no editing was done whatsoever.

In particular, I tried to edit the prints of the button pressing confirmations, from:

printf("Button1Callback : PB1 pressed \r\n");

to:

printf("Hello world! \r\n");

Then I did a clean and a build, but the virtual console, when I press the button1, still prints "Button1Callback......" instead of "Hello world!". I also tried adding some more printf even in the main, but no matter what, the application still behaves like I didn't change any line of the LEdAndButton code template, thus not displaying any of the added printfs and doesn't update the output of the ones I edited.

0 (0 Voti)
RE: XDK console not printing anything.
Risposta
25/09/19 8.30 come risposta a Lorenzo Vottero.

Hi Lorenzo Vottero,

I also edited the code prints of button pressing conformations as

printf("Helloworld : PB1 pressed \r\n");

Then I cleaned and built the project and I was able to print  "Helloworld : PB1 pressed"in the console whenever I press Button 1(Image is attached for reference).

Can you check with latest version of Workbench 3.6.0

 

0 (0 Voti)