RE: Unable to do FOTA using leshan LWM2M
응답
18. 6. 19 오전 6:35 as a reply to Alexander Sawtschuk.

Hello Sir,

 I am trying to downsize the BoschXdkCloudConnectivity example; I have removed all the unnecessary but whenever I am building the project I am getting error

 make[1]: *** No rule to make target '/root/XDK-Workspace/CloudConnect/debug/objects/Lwm2mObjects/Lwm2mObject_Humidity.o', needed by '/root/XDK-Workspace/CloudConnect/debug/CloudConnect.out'.  Stop.
recipe for target 'debug' failed 

I am unable to figure out the error?

Best Regards,

Kedar 

0 (0 투표)
RE: Unable to do FOTA using leshan LWM2M
응답
18. 6. 19 오전 7:41 as a reply to Kedar Dahivale.

Hello ,

     I have fund the waz around that error , I needed to remove application file declaration from make file.

0 (0 투표)
RE: Unable to do FOTA using leshan LWM2M
응답
18. 6. 19 오전 11:27 as a reply to Kedar Dahivale.
Hello Kedar,

I am glad to hear that you were able to solve the error.

Kind regards,
Alex
0 (0 투표)
RE: Unable to do FOTA using leshan LWM2M
응답
18. 6. 20 오후 1:05 as a reply to Alexander Sawtschuk.

Hello ,

    I would like to update on issue, currently I am facing strange issue which is as follows,

There is no FIRMWAREUPDATE.BIn file on SD card yet whenever XDK connects to leshan and if I read the resource /5/0/3 it shows me value 2 and at resource /5/0/5 = 8 attaching th escreenshot of the same.

please guide,

Best Regards,

Kedar Dahivale

0 (0 투표)
RE: Unable to do FOTA using leshan LWM2M
응답
18. 6. 21 오후 2:13 as a reply to Kedar Dahivale.
Hello Kedar,

This is indeed strange behavior.

Just for clarification, you used the same Californium Server you used for Firmware Updates with the original BoschXdkCloudConnectivity example. Is that correct? Or have you made any modifications after that?

Additionally, which version of the BoschXdkCloudConnectivity are you using now? The original one, the downsized one, or the one rebuilt from scratch that only implements FOTA?

After looking into the FOTA source code of the Platform implementation, I have noticed that the implementation uses the SD Card, but it does not initialize it. Do you have code for initializing the SD Card Driver and mounting the partition on the SD Card?

If this is not the case, I would recommend to take a look into the SD Card Guide in the Learning Section . This guide features code snippets for initializing the SD Card Driver and mounting the partition.

Otherwise, I would recommend to take a look at the network traffic between your XDK and the Californium Server (using Wireshark or something similar), to determine if the firmware is being downloaded at all.

Please let me know if this was helpful and feel free to ask if you have any further questions.

Kind regards,
Alex
0 (0 투표)