Sending data via UART
응답
15. 7. 14 오전 9:02 as a reply to Wang Ben.
Dear Chris,

Have you enabled the clock of the port you use? Look above in my working code:
CMU_ClockEnable(cmuClock_UART1, true);
Without this line, SER_serialWrite only fills the buffer, but the data will never be sent to the pins. When the buffer is full, the function returns 2.
I hope I could help.

Bye,

Jürgen
 
0 (0 투표)
Sending data via UART
응답
15. 7. 15 오전 2:29 as a reply to Jürgen Schuster.
Dear Jürgen,

actually I am using exactly your code. I just copied it because I couldn't get mine running. I asked you again since I can't get your code working as well....

Best regards,
Chris
 
0 (0 투표)
Sending data via UART
응답
15. 7. 15 오전 5:54 as a reply to Wang Ben.
Dear Chris,

On our XDKs my code works without problems. And the complete code is not much more than the snippet I posted. Just some code to read out the sensors and put the values in the sending string. I have no idea why this doesn't work for your project, I'm sorry. I think I can send you the complete .c file if this helps, so let me know.

Bye,

Jürgen
 
0 (0 투표)
Sending data via UART
응답
15. 7. 16 오전 7:09 as a reply to Jürgen Schuster.
Dear Jürgen,

thank you for the offer of sending me your code! I would really appreciate it!
My mail address:

Best regards,
Chris
 
0 (0 투표)
RE: Sending data via UART
응답
16. 8. 4 오전 6:40 as a reply to Wang Ben.

Hey,

This post was a while ago but I am experiencing a similar issue.

 How are you definging init.txBuf_p and what is serialTxBuffer and how is it defined? Im struggling with this part and not really sure how to get past it.

 

Thanks! 

0 (0 투표)